wordpress-ping-optimizerを更新したらWarningが出てしまった

TOOL, WordPress

PHP7.2対応が必要らしいので対応してみました。ただし私は普段PHPを書いたことがほとんどない、C#野郎なので誤っていたらごめんなさい。

Warning: count(): Parameter must be an array or an object that implements Countable in /url/wp-content/plugins/wordpress-ping-optimizer/cbnet-ping-optimizer.php on line 533

エラーではないけれど警告が出ているので調べてみると配列チェックしてくれといった内容でしたので、プラグインエディターで該当箇所のソースファイルを開き、533行目の

$pingCount=count($this->cbnetpo_future_pings);

こちらを

if(is_array($this->cbnetpo_future_pings)){
	$pingCount=count($this->cbnetpo_future_pings);
}

とすることで回避できました。